API Forum

This forum is in read-only mode.
Please refer to our API support in case you have any questions.
We can be reached at api@e-conomic.com
e-conomic API developer forum

Failed to load external entity

0
HI, i'm trying to connect to e-conimic but I get an error.

Warning SoapClientSoapClient() soapclientsoapclient I/O warning  failed to load external entity https//wwwe-conomiccom/secure/api1/EconomicWebserviceasmx?WSDL in C\xampp\htdocs\PHP\test1php  on line 6

Fatal error Uncaught SoapFault exception WSDL SOAP-ERROR Parsing WSDL Couldn't load from 'https//wwwe-conomiccom/secure/api1/EconomicWebserviceasmx?WSDL'  failed to load external entity https//wwwe-conomiccom/secure/api1/EconomicWebserviceasmx?WSDL in C\xampp\htdocs\PHP\test1php6 Stack trace #0 C\xampp\htdocs\PHP\test1php(6) SoapClient-SoapClient('https//wwwe-c', Array) #1 C\xampp\htdocs\PHP\test1php(19) ecConnect() #2 {main} thrown in C\xampp\htdocs\PHP\test1php on line 6


This is the function i use

//Connect to e-conomic
function ecConnect($agNr,$user,$pass) {
    $apiUrl = 'https//wwwe-conomiccom/secure/api1/EconomicWebserviceasmx?WSDL';
    $client = new SoapClient($apiUrl,array(trace = 1, exceptions = 1)); //Line 6
    $client-Connect(array(
        'agreementNumber' = $agNr,
        'userName' = $user,
        'password' = $pass));
    return $client;
}


I can't see anything wrong with it.
I'm a newbie at PHP, so i might miss something...
created Jun 24, 2010 by Madman
0% Accept Rate
Q 5 A 13 C 0

2 Answers

0
Okey, i commented openssl and restarted server and then uncommented it again, and restart server, and now it work...
answered Jun 24, 2010 by Madman
0
That comment right what i what to type

to all ordere pepole outsite.

besure you have install OpenSSL on Apache if you use Linux/Unix server, and REMEBER to restart your webserver aftere that, if you dont do that, you can't use HTTPS to SOAP call in PHP
answered Nov 17, 2010 by ParisNakitaKejser
Visma e-conomic A/S
...