API Forum

This forum is in read-only mode.
Please refer to our API support in case you have any questions.
We can be reached at api@e-conomic.com
e-conomic API developer forum

Hastighed på API?

0
Er der andre der har problemer med at det tager nogle sekunder at connecte via den udleverede DLL?


Mvh Michael Bojsen
created Sep 16, 2009 by TheManDK
0% Accept Rate
Q 3 A 1 C 0

5 Answers

0
Oplever ligeledes regelmæssige timeouts på API'et.. Så du er ikke den eneste.
answered Sep 19, 2009 by Adnecto
0
Det er et kendt problem, at det godt kan tage 5-8 sekunder at oprette vores session, så derfor kan det godt tage lang tid at connecte.

Men når du først har adgang, burde der ikke være nogle performance problemer. Hvis du ofte oplever timeouts, skal du være velkommen til at kontakte os, så kan vi kigge ind på det.

Henrik Christensen
e-conomic
answered Sep 29, 2009 by hch
0
hej

Er det sat noget udvikling fra e-conomics side i verden for at bringe denne første adgang til en session ned i tid ?

Ved implementering af en kundevendt applikation på web, er 5-8 sek. ( som i virkligheden ofte er højere ) lææææænge af vente for en bruger.

Håber der bliver sat fokus på dette .....
answered Apr 13, 2012 by ekontoret.dk
ser ud til at være rettet i ny version af API
0
Hej
Disse 5-8 sekunders connection problem, er der fortsat ingen planer om at tage hånd om dette?
answered May 30, 2012 by Jacob_2500
0
Gennem 3 år har jeg vænnet mig til - ved første opkald - at skulle vente ca 30 sek på download af et eller andet library med mit langsomme tdc abonnement (2Gb/512kb), men så viser websiden sig også i min browser og det hele fungerer efterfølgende fint med korte svartider.

Jeg refererer til e-conomic's .NET demonstrationsprogram, som jeg har kompileret gennem 3 år med VS 2008 Pro under .NET 3.5 sp1.

De færdigkompilerede filer overføres til en webserver hvor det kan betragtes som en slags demo af et add-on som jeg udvikler på. Her har det så også taget ca 30 sekunder før programmet dukker op, men så virker det også fint efterfølgende.        http//wwwjoebottlerdk/phxhtm     

Forleden begyndte programmet så pludselig at fungere anderledes. Der var stadig ventetid før e-conomic demo-skærmbilledet dukker op, men programmet collapsede med en fejlmeddelelse når man trykkede på én af funktions-knapperne.

På min localhost var der ingen problemer og hostmasteren for den eksterne webserver sagde, at intet var ændret dér.

Mit spørgsmål var - om man hos e-conomic har ændret i afviklingen af denne Web Service i den sidste uges tid ? - det havde man ikke.
-------------------- problemet opklaret

Hej igen, jeg har netop fået følgende tilmagemelding fra min eksterne webserver:
 
Hej, vores administrator har lukket for port 80 i vores firewall - jeg har bedt ham om at få den genåbnet og regner med at det sker senest i morgen. - Hilsen xxxx

-------------------- alt er nu i orden
answered Sep 22, 2012 by Leif Mønniche
Visma e-conomic A/S
...