API Forum

This forum is in read-only mode.
Please refer to our API support in case you have any questions.
We can be reached at api@e-conomic.com
e-conomic API developer forum

BUG in 'OrderLine_SetProduct'?

0
Hi Forum

I think i have found a bug in the API.

When I use the function  'OrderLine_SetProduct' and fil in the producthandle everything works fine. Exept one thing!

When i enter the webinterface of Economic only the productnumber is shown. By some reason the productname field is empty.

First when I open the editor of the orderline and reenter the product manually the productname becomes visible.

And that is not possible if I already via the API have registret the order as sent.

Regards Christian Heyn
created Aug 23, 2013 by cheyn
87% Accept Rate
Q 15 A 6 C 7

1 Answer

0
 
Best answer
Hi Christian,

When setting the product reference in the GUI, the description will automatically be suggested (taken from the product's name in the product register), and the unit price will also be suggested as defined in the product register. However, you are of course free to change these before saving the line.

In the API, you must EXPLICITLY set all parameters - e.g., in this case, set the line's Description to the product's Name (unless you want another description for the specific line, of course :-))

 

Best regards,
answered Aug 23, 2013 by Christian Estrup
selected Aug 26, 2013 by cheyn
Do this mean that i actually cant fill out field for productname, but only have the possibility to fill it into description?
Ok - I see your point
Description is actually the productname.
Sorry calling it a bug.
The description on the order line is "how you want to describe the product on the order line". In many cases, this will in practice be the product name.
Visma e-conomic A/S
...